注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

about blank

PEM`s Enhanced Memories

 
 
 

日志

 
 

LuaTeX zlib library version 不匹配的问题  

2010-03-24 01:02:28|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
前些天把机器上的TeXLive升级 了下,今天突然发现dvipdfm不work了。

[pem@pemryan chapter]$ dvipdfm chap-misc.dvi

chap-misc.dvi -> chap-misc.pdf

[1][2PANIC: unprotected error in call to Lua API (zlib library version does not match - header: 1.2.3.4, library: 1.2.4)

** WARNING ** Filtering file via command -->rungs -q -dNOPAUSE -dBATCH -sPAPERSIZE=a0 -sDEVICE=pdfwrite -dCompatibilityLevel=1.4 -dAutoFilterGrayImages=false -dGrayImageFilter=/FlateEncode -dAutoFilterColorImages=false -dColorImageFilter=/FlateEncode -sOutputFile=/tmp/dvipdfmx.XC06i7c ../figures/KM.eps -c quit<-- failed.

** WARNING ** Image format conversion for "../figures/KM.eps" failed...

** ERROR ** pdf_ref_obj(): passed invalid object.

Output file removed.


原因是有个inkscape里面svg导出的eps图,插入时出了问题。Google未果,看出错就是zlib版本不匹配,想来是LuaTeX是用旧版的zlib编译的,刚好我又把zlib给升级了。


于是抓来源码,用新的zlib把LuaTeX编译了一遍,好了。其实我现在一点一点都不想折腾这些东西,都是不难搞定的问题,就是费时和分神,影响做正事的效率。于是下定决心一年内绝不升级系统了,或者现在的心态适合去用windows。不过这些年来已经重度依赖Linux DE,攒下不少配置和文档,还是不来回折腾的好。



  评论这张
 
阅读(351)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018